Bash up to 4.3 ran commands hidden behind function definitions in environment variables.
Published in the NVD on 24/09/2014
In the CISA catalogue of actively exploited vulnerabilities since 28/01/2022
Exploitation probability (EPSS, 01/11/2026): 99.999 %, percentile 99.993
Shellshock is a flaw in GNU Bash up to 4.3. Bash executed trailing commands after a function definition in the value of an environment variable. Wherever an environment variable crosses a privilege boundary into Bash, an attacker can run code, for example through CGI scripts in the Apache HTTP Server, DHCP clients or the ForceCommand feature of OpenSSH.
The NVD rates it at CVSS 9.8, and CISA has listed it as actively exploited since 28 January 2022. The first fix was incomplete; the remaining problem has its own identifier, CVE-2014-7169.
Affected: <= 4.3
No fixed version given in the NVD data
Fixed from package version 4.3-9.1
Fixed from package version 4.3-9.1
Fixed from package version 4.3-7ubuntu1.1
Install the bash security update of your distribution, which also covers the follow-up flaws. Debian 12 and 13 ship Bash 5.2 with the fix.
Erseni Patch tells you when a new vulnerability affects exactly your version, and when your release branch loses its support. Add the program or package with your version and we check it right away.
Already have an account? Log in and add bash (Debian 12)
Facts checked on 02/11/2026 against NVD, CISA KEV, FIRST EPSS, the Debian Security Tracker and OSV.